Unable to delete Library through the digi.me app
Incident Report for digi.me
Resolved
This incident has been resolved.
Posted 2 months ago. Jun 14, 2019 - 15:53 BST
Identified
We have been made aware of an issue preventing some users from deleting their library in the digi.me app. We are planning to resolve this as soon as we can.

If you require any assistance deleting your digi.me library, please contact our support team via https://digi.me/support
Posted 3 months ago. May 22, 2019 - 17:25 BST
This incident affected: digi.me Servers.