Dropbox Authentication Failing
Incident Report for digi.me
Resolved
This issue with the Dropbox site is no longer affecting digi.me.
Posted Nov 27, 2019 - 08:22 GMT
Monitoring
We're aware of an issue affecting Dropbox login for a small amount of users. This results in being stuck on the login page and occasionally seeing an error message.

If you encounter this issue, please reach out to our support team who will be happy to help.
Posted Nov 20, 2019 - 16:08 GMT