Performance issues with digi.me Private Sharing
Incident Report for digi.me
Resolved
This incident has been resolved.
Posted Nov 15, 2019 - 17:38 GMT
Monitoring
We have identified some performance issues with our Private Sharing system and are currently monitoring the area. This may cause some slow-downs when sharing your data with another app.
Posted Oct 24, 2019 - 17:11 BST
This incident affected: digi.me Private Sharing.