Connection issues with Citi
Incident Report for digi.me
Update
Our financial service provider's connection to Citi is currently offline due to an increased number of failures in their systems.
Posted Feb 03, 2020 - 14:46 GMT
Investigating
Our financial service provider is currently having issues connecting to Citi, affecting login and transaction import. We'll post an update when we receive any further information about this incident.
Posted Jan 27, 2020 - 09:22 GMT
This incident affects: SERVICES - Finance (USA Banks).