Private Sharing requests failing for some large digi.me libraries
Incident Report for digi.me
Resolved
This incident has been resolved.
Posted 23 days ago. Sep 30, 2019 - 14:57 BST
Identified
We have identified the cause of this issue affecting some Private Sharing requests and the team are currently working on a fix.
Posted 26 days ago. Sep 27, 2019 - 14:36 BST
This incident affected: digi.me Private Sharing and digi.me Servers.